If you configure your field naming preferences in options (Options / Languages / Common / Naming Style), ReSharper will derive better names for properties and other entities when generating code.
I use this to a very limited extent, but it doesn't do exactly what I want: instance fields: _camelCase static fields: _PascalCase parameters: camelCase local variables: camelCase
Mostly R# does what I want in this respect, except for instance fields. If this were configurable it would be better.
I second this one - Resharper always gets it wrong with instance fields using the _camelCase abbreviation which is our standard as well. If I have a property "Width" with a class variable _width, then rename the property to "SomeWidth", Resharper suggests "_SomeWidth" not "_someWidth".
2 comments:
I use this to a very limited extent, but it doesn't do exactly what I want:
instance fields: _camelCase
static fields: _PascalCase
parameters: camelCase
local variables: camelCase
Mostly R# does what I want in this respect, except for instance fields. If this were configurable it would be better.
I second this one - Resharper always gets it wrong with instance fields using the _camelCase abbreviation which is our standard as well. If I have a property "Width" with a class variable _width, then rename the property to "SomeWidth", Resharper suggests "_SomeWidth" not "_someWidth".
Post a Comment